Welcome to Bukkit France

Inscrivez-vous maintenant pour profiter d'un accès total à tout le contenu offert par la meilleur communauté Bukkit française ! Une fois inscrit et connecté, vous pourrez contribuez à la communauté en postant vos propres sujets et questions ou en répondant à ceux existants. Vous pourrez aussi customiser votre profil, recevoir des points de réputations, communiquer avec les autres membres via le chat, et plus encore! 

  • Annonces

    • Pskyco

      Bukkit France passe sous Discord !   20/02/2016

      Bukkit France est désormais passé sur Discord, au revoir donc notre vieux Teamspeak ! Téléchargez le client et venez nous rejoindre sur notre salon en suivant les instructions suivantes.
sikux

Aide JSONAPI Bungeecord

19 messages dans ce sujet

Plateforme : Spigot
Version : 1.10
Plugin concerné : JSONAPI
Explications du problème rencontré : J'ai bien installer JSONAPI et je les bien configurer enfin il me semble mais impossible de trouver mon serveur sur le cms.
Recherches effectuées : Google et plusieurs forums
Liste des plugins présents sur votre serveur : TuxTwoLib, ObsidianBreaker, WorldEdit, KillCash, MassiveCore, ColoredSigns, ChangeMessages, Vault, PermissionsEx, Multiverse-Core, WorldGuard, AutoMessage, BuyPack, ClearLag, ProtocolLib, AreaShop, iConomy_Recreation, Essentials, AncientGates, CommandSigns, NoCheatPlus, EssentialsSpawn, SpawnerShop, PlayerMarkers, KitAdder, JSONAPI, PlayerHeads, Orebfuscator4, EssentialsChat, Factions
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Logs du serveur + la config de JsonApi, stp. :)

1 personne aime ça

Partager ce message


Lien à poster
Partager sur d’autres sites

[08:03:29] [Server thread/INFO]: [JSONAPI] Enabling JSONAPI v5.7.0
[08:03:29] [Server thread/INFO]: [JSONAPI] Logging to file: false
[08:03:29] [Server thread/INFO]: [JSONAPI] Logging to console: true
[08:03:29] [Server thread/INFO]: [JSONAPI] IP Whitelist = None, all requests are allowed.
[08:03:29] [Server thread/INFO]: [JSONAPI] Loaded methods.json.
[08:03:29] [Thread-29/INFO]: [JSONAPI] Waiting 2.000 seconds to load methods so that all the other plugins load...
[08:03:29] [Thread-29/INFO]: [JSONAPI] Any requests in this time will not work...
[08:03:29] [Server thread/INFO]: [JSONAPI] Attempting to use port 35623

 

[08:03:31] [Thread-29/INFO]: [JSONAPI] Dynmap cannot be loaded because it depends on a plugin that is not installed: 'dynmap'
[08:03:31] [Thread-29/INFO]: [JSONAPI] Remote Toolkit cannot be loaded because it depends on a plugin that is not installed: 'RemoteToolkitPlugin'
[08:03:31] [Thread-29/INFO]: [JSONAPI] Dynmap cannot be loaded because it depends on a plugin that is not installed: 'dynmap'
[08:03:31] [Thread-29/INFO]: [JSONAPI] Remote Toolkit methods cannot be loaded because it depends on a plugin that is not installed: 'RemoteToolkitPlugin'
[08:03:31] [Thread-29/INFO]: [JSONAPI] 386 methods loaded in 7 namespaces.
[08:03:31] [Thread-29/INFO]: [JSONAPI] ------[Connection information]-------
[08:03:31] [Thread-29/INFO]: [JSONAPI] JSON Server listening on 35623
[08:03:31] [Thread-29/INFO]: [JSONAPI] JSON Stream Server listening on 35624
[08:03:31] [Thread-29/INFO]: [JSONAPI] JSON WebSocket Stream Server listening on 35625
[08:03:31] [Thread-29/INFO]: [JSONAPI] Active and listening for requests.
[08:03:31] [Thread-29/INFO]: [JSONAPI] External IP: Enlevé
[08:03:31] [Thread-29/INFO]: [JSONAPI] Port 35623 is properly forwarded and is externally accessible.
[08:03:31] [Thread-29/INFO]: [JSONAPI] Port 35624 is properly forwarded and is externally accessible.
[08:03:32] [Thread-29/INFO]: [JSONAPI] Port 35625 is properly forwarded and is externally accessible.
[08:03:32] [Thread-29/INFO]: [JSONAPI] -------------------------------------

 

# API methods on the method-whitelist will be
# able to called without any sort of authentication
method-whitelist:
- getPlayerLimit
- dynmap.getPort
options:
  stream_pusher:
    max_queue_age: 30
    max_queue_length: 500
  startup-delay: 2000
  port: 35623
  ip-whitelist: []
  log-to-console: true
  log-to-file: 'false'
  anyone-can-use-calladmin: true
  use-new-api: false
  adminium-push-enabled: true

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 38 minutes, sikux a dit :

UP

Merci d'aller lire les règles.

3 personnes aiment ça

Partager ce message


Lien à poster
Partager sur d’autres sites

Je l'ai très bien lu juste que j'ai besoin de régler mon problème, et de laisser un message comme quoi on ne sais pas serais gentil pas besoin de me laisser attendre.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

 

Quel est le CMS que tu utilise et sur quel hébergeur héberges-tu le CMS en question ? :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Cela ne viens pas de mon hébergeur n'y du cms j'ai tester  le lien grâce à un site

Partager ce message


Lien à poster
Partager sur d’autres sites

Donnes nous quand même le nom du CMS et de l'hébergeur si cela te dérange pas :) 

Cela nous aidera d'avantage et puis JSONAPI peut fonctionner de manière différente d'un CMS/hébergeur à un autre 

Partager ce message


Lien à poster
Partager sur d’autres sites

CMS: CraftMyWebSite

Hebergeur: All-hereg

Partager ce message


Lien à poster
Partager sur d’autres sites

Hum... 

 

On va voir si ta connexion JSONAPI fonctionne correctement, utilises ce site web http://alecgorge.github.io/jsonapi/, entres l'ip de ton serveur (SANS LE PORT DE TON SERVEUR), ensuite entre le port de JSONAPI ET PAS DE TON SERVEUR, ensuite entre le Username ainsi de la mdp que tu as défini dans le fichier users.yml. Laisse vide la case avec le Salt et appuie sur Login

 

Ensuite envoie moi un screen de ce qui s'affiche, on pourra voir si le problème vient de ton hébergeur minecraft ou de l'hébergeur de ton CMS

 

 

Et un autre question, sur quel hébergeur se trouve ton serveur Minecraft ? Il est également chez All-Heberg ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Mon serveur Minecraft est sur un VPS qui est heberger chez DEDISHOP 

Pour le test cela reste en Testing Connection

Partager ce message


Lien à poster
Partager sur d’autres sites

Essaye de refaire la même manip que précédemment mais cette fois sur ce site : http://octodev.fr/tools/jsonapi/ (car je crois que le site d'avant est assez vieux et n'est pas toujours très fiable)

 

Si jamais cela t'affiche un message c'est qu'il y a de fortes chances que cela viennent de la où est héberger ton plugin jsonapi (en l'occurence sur ton serveur)

 

Je te conseille déjà de voir avec le support de dedishop si ils ont ouvert le port qui tu as dédié du plugin : 35623 (à moins que tu puisse directement ouvrir les ports depuis le VPS) et ensuite re-tester la connexion JSONAPI

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

A tu une idée de comment ouvrir les port ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Les port TCP de mon serveur sont ouvert mais rien de change.

Es que JSONAPI a besoin du port UDP.

Partager ce message


Lien à poster
Partager sur d’autres sites

Essaye de changer dee port jsonapi ... Réinstalle le ... et ... tu met l'external ip + le port  35623

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !


Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.


Connectez-vous maintenant

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.