Welcome to Bukkit France

Inscrivez-vous maintenant pour profiter d'un accès total à tout le contenu offert par la meilleur communauté Bukkit française ! Une fois inscrit et connecté, vous pourrez contribuez à la communauté en postant vos propres sujets et questions ou en répondant à ceux existants. Vous pourrez aussi customiser votre profil, recevoir des points de réputations, communiquer avec les autres membres via le chat, et plus encore! 

KinderrKill

Membres
  • Compteur de contenus

    353
  • Inscription

  • Dernière visite

Réputation sur la communauté

83 Fréquentable

4 abonnés

À propos de KinderrKill

  • Rang
    #Error 404# Title not found
  • Date de naissance 11/12/95

Me contacter

  • Minecraft KinderrKill
  • Site Web http://companyofcube.fr/
  • Skype companyofcube
  • Steam Kinderrkill
  • Twitter kinderrkill
  • Youtube kinderrkill

Informations de profil

  • Sexe Homme

Visiteurs récents du profil

518 visualisations du profil
  1. Bonjour, bonjour, je viens vers vous car je suis devant un problème et je n'arrive pas à trouver une solution. Avant tout voici quelques informations :   Version 1.8.8 (Client / Spigot) Je n'utilise pas Forge   Alors le problème à l'air simple, j'arrive à lancer mes musiques customs via un   PositionedSoundRecord.createPositionedSoundRecord(new ResourceLocation("music.menu"));   J'ai bien sûr dans mon sound.json définis mon son avec sa catégorie   "music.menu": { "category": "music", "sounds": [ { "name": "music/menu/menu_1", "stream": true }, { "name": "music/menu/menu_2", "stream": true }, { "name": "music/menu/menu_3", "stream": true } ] }, Le problème est que je ne peux pas stopper mon son une fois lancer, car quand je cible avec un stopSound, le jeu ne fais rien et après avoir fait pas mal de test, ne reconnais pas mon son en tant que tel.   Je me demande donc si il ne faut pas déclarer autrement mon son pour pouvoir interagir avec dans Minecraft, car il me le lance, mais n'a aucun contrôle dessus, le seul moyen de l'arrêter c'est de stopper tout les sons.   J'ai déjà fais beaucoup de tests mais ne trouvant pas la solution je me tourne vers vous. Cordialement KinderrKill ! Merci d'avoir prêter attention à ce sujet.
  2. EDIT : Après avoir isoler chaque class et chaque fonction, j'ai trouvé mon erreur, une bête fonction qui est prioritaire par rapport à une autre et qui du coup à chaque event openInventory, le fermais. Erreur stupide de ma part.   Version : 1.8.8 Spigot IDE : Eclipse Erreur : Depuis peu mes fonctions openInventory ne fonctionne plus. Code erreur : Aucun tout à l'air normal, sauf que rien ne s'affiche. Code : GuiBase   GuiCustomInventory     Et pour l'ouvrir, via une commande de type "/guicustom open" je fais new GuiCustomInventory().open((Player)sender);   Je tiens à signaler que tout marchais très bien il y a quelques jours, je ne sais pas à quoi j'ai touché, mais maintenant l'event ne fonctionne plus. > Edit : Je viens de me rendre compte que tout les plugins qui comporte un player.openInv ne fonctionne pas à cause de mon plugin. Donc il doit y avoir quelques choses d'important qui fait tout planter, mais sans message d'erreur c'est compliqué de savoir où chercher.   J'ai bien regardé chaque class de mon plugin, je ne voit pas ce qui peux empêcher ça, j'ai laisser juste mon plugin pour faire un test en cas d'incompatibilité avec d'autre mais ce n'est pas ça, c'est dans mes codes, mais je ne voit vraiment pas où :/   Si quelqu'un pense avoir une idée du pourquoi du comment je suis preneur ! Merci d'avance pour votre aide !
  3. Edit : Erreur dans la class d'envoi du packet, erreur d’inattention, désolé jai posté la demande d'aide trop vite sans prendre le temps de bien regarder mon code avant.   Bonjour, tout d'abord voici les informations utiles :   Version : 1.8 Ide : Eclipse Merci à vous de préter attention à ce sujet, je vais l'expliquer un peu plus. J'ai actuellement un système de quête qui passe via les PNJ de citizen, donc à chaque création de PNJ j'utilise un packet pour envoyer les informations du PNJ au client. Avant tout marcher très bien, j'ai touché a mon client (pour ajouter des tas de choses) mais je n'ai plus touché à mon système de quête (étant fonctionnel). Mais là, quand je créer un PNJ je suis kick du serveur avec cette erreur. Image Erreur   Et quand je me reconnecte j'ai bien mon PNJ et les informations sont bien transmises à mon client. Je suis un peu perdu je doit l'avouer, merci d'avance à vous pour vos avis / conseils. Si vous avez besoin d'autres informations, je suis pas loins  
  4. EDIT : Problème réglé à cause d'une incohérence dans les noms d'un bloc Client / Serveur   Version : Spigot 1.8.8 IDE :       Eclipse   Bonsoir à vous ! Tout d'abord merci de prêter attention à ce sujet.   Je reprend le développement après plusieurs mois d'absence et je suis un peu rouillé, en ré ouvrant Minecraft j'ai eu une erreur sur tout mes ArmorStand, un cube Violet / Noir (Objet inconnus) on pop sur leurs mains droites, et ça me spam en boucle une erreur OpenGL dans la console    [17:16:53] [Client thread/ERROR]: ########## GL ERROR ########## [17:16:53] [Client thread/ERROR]: @ Post render [17:16:53] [Client thread/ERROR]: 1283: Stack overflow [17:16:53] [Client thread/ERROR]: Couldn't render entity java.lang.NullPointerException at net.minecraft.item.ItemStack.hasEffect(ItemStack.java:883) ~[bin/:?] at net.minecraft.client.renderer.entity.RenderItem.func_180454_a(RenderItem.java:203) ~[bin/:?] at net.minecraft.client.renderer.entity.RenderItem.func_175040_a(RenderItem.java:441) ~[bin/:?] at net.minecraft.client.renderer.entity.RenderItem.func_175049_a(RenderItem.java:380) ~[bin/:?] at net.minecraft.client.renderer.ItemRenderer.renderItem(ItemRenderer.java:80) ~[bin/:?] at net.minecraft.client.renderer.entity.layers.LayerHeldItem.doRenderLayer(LayerHeldItem.java:72) ~[bin/:?] at net.minecraft.client.renderer.entity.RendererLivingEntity.func_177093_a(RendererLivingEntity.java:516) ~[bin/:?] at net.minecraft.client.renderer.entity.RendererLivingEntity.doRender(RendererLivingEntity.java:206) [bin/:?] at net.minecraft.client.renderer.entity.RendererLivingEntity.doRender(RendererLivingEntity.java:675) [bin/:?] at net.minecraft.client.renderer.entity.RenderManager.doRenderEntity(RenderManager.java:403) [bin/:?] at net.minecraft.client.renderer.entity.RenderManager.renderEntityStatic(RenderManager.java:360) [bin/:?] at net.minecraft.client.renderer.entity.RenderManager.renderEntitySimple(RenderManager.java:327) [bin/:?] at net.minecraft.client.renderer.RenderGlobal.func_180446_a(RenderGlobal.java:773) [bin/:?] at net.minecraft.client.renderer.EntityRenderer.func_175068_a(EntityRenderer.java:1718) [bin/:?] at net.minecraft.client.renderer.EntityRenderer.renderWorld(EntityRenderer.java:1521) [bin/:?] at net.minecraft.client.renderer.EntityRenderer.updateCameraAndRender(EntityRenderer.java:1313) [bin/:?] at net.minecraft.client.Minecraft.runGameLoop(Minecraft.java:1152) [bin/:?] at net.minecraft.client.Minecraft.run(Minecraft.java:435) [bin/:?] at net.minecraft.client.main.Main.main(Main.java:115) [bin/:?] at Start.main(Start.java:11) [bin/:?]   Le problème est sur les ArmorStand, j'en place une c'est parfait, et quand je reload et que je me reconnecte sur le serveur, paf même problème (Multijoueur seulement, en solo le problème n'est pas présent). J'ai enlevé tout les plugins sur serveur et l'erreur se produit quand même donc il s'agit du Spigot ou du Client Le deuxième problème étant que ça fait bien trop longtemps que je n'ai pas touché au code et je ne sais pas du tout par où commencer. Donc tout aide est apprécié pour m'aider à comprendre et à localiser l'erreur histoire de la corriger Merci d'avance à vous ! Si vous voulez plus d'informations n’hésitez pas 
  5. Crash de divers serveur minecraft, nouveau "hack" ?

    Nous avons l'ensemble des serveurs rapporté l'erreur à Spigot, merci à vous !
  6. Bonjour, bonsoir, si je viens ici c'est pour vous demander des renseignements, depuis hier soir, différents serveur minecraft, sont victimes de crash, je m'explique : Le joueur se connecte, spam un texte, et 2 secondes plus tard le serveur crash, le problème c'est que la sacktrace est très étrange Je vous la poste ici : http://pastebin.com/AEWaSUaS   Plusieurs minutes après le serveur se relance, mais voilà depuis hier soir, différent pseudo / ip avec toujours le même message, et même crash. En tous cas ce n'est pas l'œuvre d'un amateur. Nous avons plusieurs pistes mais aucune n'est vraiment fondés, j'aimerais donc avoir votre avis expert sur cela. Merci d'avance !
  7. Détection d'un bloc en dessous d'un minecart

    Essaye p.getVehicle().getLocation().getBlock()  Je n'ai pas essayé mais ça devrais être comme ceci
  8. Bonjour, bonsoir, merci de prêter attention à ce sujet Version : 1.8.8   J'ai créer une entité custom via NMS, j'ai réussis à la faire spawn et à en faire mon esclave (monture) Le seul petit hic, c'est que la tête du mob fait n'importe quoi, soit elle reste bloqué dans une direction, soit elle "bug" en bougeant dans tout les sens, j'ai fouiller un peu partout mais je n'ai pas trouver la solution, j'aimerais d'une part, quand je bouge la tête, celle de l'entité suive ce mouvement, mais aussi (je ne sais pas si c'est possible) quand j'avance, pouvoir me déplacer via la souris et non uniquement ZQSD. Voici le code de mon entité custom         Ensuite pour le spawn   CustomPig pig = new CustomPig(((CraftWorld) p.getWorld()).getHandle()); pig.spawnIn(((CraftWorld) p.getWorld()).getHandle()); pig.setSaddle(true); pig.setLocation(p.getLocation().getX(), p.getLocation().getY(), p.getLocation().getZ(), p.getLocation().getPitch(), p.getLocation().getYaw()); ((CraftWorld) p.getWorld()).getHandle().addEntity(pig); ((CraftPlayer) p).getHandle().mount(pig);   Merci bien pour votre future aide !   Je reste à disposition pour vous fournir plus ample information ! Da bisous à vous !
  9. Bukkit class CustomPlayer

    Personnellement j'utilise ce genre de méthode pour le custom XP Après à toi d'adapter selon t'es envie   public void customAddXp(Player p, float amount) { //Tu fait ton calcul pour la réduction d'xp //amount = amount/4; float oldTotalXP = p.getTotalExperience(); float newTotalXP = oldTotalXP + amount; p.setXP(newTotalXP); }   Un truc du genre    
  10. Bukkit class CustomPlayer

    Bonjour bonjour, pourrais tu préciser, en gros tu souhaite faire un système de leveling comme dans les RPG ?
  11. ShapedRecipe avec un ItemStack custom

    Hello ! Essaye donc apcraft.setIngredient('P', pen.getData());  Vu qu'il faut un Material / MaterialData    
  12. GL ERROR 1283 "Couldn't render entity"

    Hinnax, oui justement j'ai regardé et remonter mais pour moi ça me semble incohérent d'où la demande d'aide ici, oui j'enregistre des items customs, mais ils sont tous "basiques" donc je ne voit pas en quoi ça pourrais planter, et je confirme que ça viens de spigot, spigot clean j'ai aucune erreur, je remplace avec mon sigot modifié j'ai une erreur Hinnax, tu peux regarder dans le topic principal j'ai mis mes class ItemCustom que j'utilise pour enregistrer, c'est peux être le chargement qui est pas bon je ne sais pas :/   EDIT : j'ai refais bien mes class ItemList / Items & BlockList / Blocks   Et j'ai réussi à cerner un peu plus le problème lorsqu'un armorstand charge les items qu'il possède, c'est là que l'erreur se cause, car peux importe ce que je lui équipe, je voit dans ça main un blocs sans texture, et le    public boolean hasEffect() { return this.getItem().hasEffect(this); }   retourne l'erreur OPENGL, donc je pense que l'erreur viens du chargement de l'entité et de ce qu'il possède, sauf que là je ne sais pas où allez et que modifier :/   EDIT 2 : Peux importe l'entité au final, quand le jeu doit charger une entité avec un Item, j'ai l'erreur OPEN GL, (Zombie qui ramasse un item etc...)   EDIT 3 : Problème résolus, à cause d'une majuscule lors d'une déclaration de block .... merci à vous de m'avoir aider !
  13. GL ERROR 1283 "Couldn't render entity"

    TheBadCraft cela correspond a :    Main.main(concat(new String[] {"--version", "mcp", "--accessToken", "0", "--assetsDir", "assets", "--assetIndex", "1.8", "--userProperties", "{}"}, args));  
  14. GL ERROR 1283 "Couldn't render entity"

    Je corrige ça !, et oui pas de soucis ! Par contre tu viens de m'éclairer    " P.S: Que fait de l'OpenGL sur un serveur ? "   J'ai un système d'accéssoire avec Rendu sur les entités, et je ne pouvais faire les tests que en multi, vu que ça fonctionnait j'ai stop, mais lors du redémarrage effectué plus tard c'est vrais que c'est à partir de là que ça à déconné. Si tu est disponible sur Skype pour que je t'explique plus en détail avec les codes. Car ça m'étonnerais que cela vienne de ItemStack elle est "clean" dans le sens ou je ne l'ai pas touché.
  15. GL ERROR 1283 "Couldn't render entity"

    Bonjour, bonsoir à vous ! Tout d'abord quelques informations   Version : 1.8 API : Néant   EDIT : j'ai refais bien mes class ItemList / Items & BlockList / Blocks   Et j'ai réussi à cerner un peu plus le problème lorsqu'un armorstand charge les items qu'il possède, c'est là que l'erreur se cause, car peux importe ce que je lui équipe, je voit dans ça main un blocs sans texture, et le    public boolean hasEffect() { return this.getItem().hasEffect(this); }   retourne l'erreur OPENGL, donc je pense que l'erreur viens du chargement de l'entité et de ce qu'il possède, sauf que là je ne sais pas où allez et que modifier :/   EDIT 2 : Peux importe l'entité au final, quand le jeu doit charger une entité avec un Item, j'ai l'erreur OPEN GL, (Zombie qui ramasse un item etc...)   Sujet de base :   Je cherche depuis un petit bout de temps à comprendre une erreur lié à OPEN GL qui est assez compliqué, je sais que cela provient de mes modifications Spigots, mais j'aimerais savoir pour mieux cibler si le code d'erreur peux nous apprendre dans "qu'elle secteur" cette erreur est. Je pourrais effacer 1 par 1 les lignes et voir ou ça plante, mais j'aimerais en même temps comprendre cette erreur, sachant que c'est la première fois que c'est des erreurs OpenGL, donc merci d'avance pour votre aide   Je ne pourrais vous donner les codes car côté spigot j'ai un peu touché à toute les class et j'ai fais l'erreur de ne pas faire de test entre deux, mais ce qui est étrange c'est que tout fonctionne très bien, c'est seulement après un redémarrage serveur que les erreurs arrives.   Mais grossos modo je peux vous dire que côté Spigot il y a seulement, des blocs / items (simple) ainsi qu'un block TileEntity, c'est tout. Mais j'utilise des class pour lister mes items pour eviter de toucher à la class de base Item.java ou Block.java qui se compose comme ceci :   BlockList.java